GroupWise Mobility Service : Cannot connect to GroupWise administration to verify license.

  • 7025013
  • 22-Feb-2021
  • 22-Feb-2021

Environment

GroupWise 18
GroupWise Mobility Service 18

Situation

Note:  In this situation the Mobility server was not moved or it's hostname was not changed.  This issue normally can occur if there is a mismatch with GroupWise license information stored locally in a database in Mobility or it cannot connect to GroupWise Admin CA server that has the CA certificate.

When the GroupWise Mobility administrator logs into the Mobility Web Admin portal, at the top there is a gold yellow error bar that says:

 "Cannot connect to GroupWise administration to verify license.  Resolve connection issues within 12 days to avoid service interruption"

Resolution

At the Mobility server , in a terminal as "root", execute these 2 commands:

cd /opt/novell/datasync/syncengine/connectors/mobility/cli

./python ./validateGroupWiseAdmin.pyc -gc <ipAddressOfGroupWiseServer> 9710 <gwSuperUserName> <password> --verbose

./python ./validateGroupWiseAdmin.pyc -sl <ipAddressOfGroupWiseServer> 9710 <gwSuperUserName> <password> --verbose

Cause

There was a mis-match between the license information in the the Mobility database and what is stored in the GroupWise server.

Additional Information

You can use the /opt/novell/datasync/tools/mcheck utility to find out if there is a problem verifying the license information by doing :

1.   python mcheck.pyc
2.   1   System
3.   4 GroupWise Maintenance Verification

Note:  Review the resulting log in :  /opt/novell/datasync/tools/mcheck/logs/GWLicenseCheck_yyyy-mm-ddT<time>.log

If there are no errors, refer to Resolution section of this document.