All GWAVA users are unable to release quarantined messages from the GWAVA Digest Report message

  • 7024945
  • 30-Nov-2020
  • 30-Nov-2020

Environment

GWAVA (Secure Messaging Gateway) 6.5

Situation

When any user tries to release a quarantined message by clicking the RELEASE action in the quarantine digest message, they get the Firefox browser error "Unable to connect".

Resolution

1.  Performed troubleshooting for this issue as listed in the below "Additional Information" , "Troubleshooting" section.

2.  As listed under the GWAVA6.5 Web admin console, "Server / Interface Management", "Server Management", "Configure server", "IP configuration" 

  The checkbox "QMS enable SSL" as NOT checked off.  I then checked this checkbox.
  
  
3.  And in the same admin console, in the section "SSL configuration", made sure the linux path and name of the certificate and key file were correct and that the .crt and .key file were matching files.  We found out that the customer had a certificate key file that did not match the certificate, at the location listed.  The customer located the correct .key file and we copied it in.

4.  Restarted "gwavaman" with "rcgwavaman stop", no quotes.  We waited until all gwavaman processess had a status of "missing".  Sometimes in GWAVA6.5, if one of these processes does not change to "missing", you need to do a "kill -9" on the pid of the process that does not shutdown.  

5.  Lastly you restart gwava with "rcgwavaman start", no quotes.  "rcgwavaman status" should show all gwavaman process with a status of "done", when all is running.


6.  Now port 49385 IS in a listen mode and the users can now release the quarantined messages listed in the GWAVA quarantined digest message, known as the "E-Mail Restriction Report" message.

Cause

The GWAVA port 49385 was not in a listen mode, because the configured certificate .key file did not match the configured certificate.  The customer realized the certificate and key file did not match based on the names and the dates of these files.  Also QMS was not configured to use SSL.

Additional Information

Troubleshooting:

1.  When the users attempt to release any quarantined message listed inside of the GWAVA digest message, by clicking on the "Release" action, I Noted the Firefox browser error and URL and port number reference :

  "Unable to connect, Firefox can't establish a connection to the server at <gwavaHostName>:49385" 


2.  It was found that the digest message release url (hover over the digest message "Release" action ) was https://<gwavHostName>:49385 .

Note:  Port 49385 is normally the port QMS uses for SSL.

3.  Discovered information listed in the "Cause" section of this document.

4.  In the GWAVA6.5 Web admin console, as noted in the "Resolution" section of this document, it was found that "QMS enable SSL" was NOT checked off.

5.  On the GWAVA6.5 server terminal, did the command "netstat -tnlp | grep :49", no quotes.  I could see that port 
49385 was NOT in a listen mode.  Which appears to be the issue.

Note:  Make sure all the information is correct in the previously discussed "IP configuration" and "SSL configuration" sections of The GWAVA 6.5 Web Admin console.