Environment
Micro Focus Filr 4.2
Situation
After an unexpected power outage to the All-in-One Filr server, no files are seen through Filr and attempting to load the Administration Console results in the following error:
(kablink) Could not open index writer
Resolution
- Verify the Filr server has enough available disk space on the /vastorage directory
- Determine how much space is available on the /vastorage directory
- df -h /vastorage
- Determine how much space the /vastorage/search/lucene/kablink directory is using
- du -sh /vastorage/search/lucene/kablink/
- Is there enough available disk space to double the /vastorage/search/lucene/kablink/ directory?
- If yes, proceed with the steps below.
- Paste the following contents into a terminal session (such as putty or other tool):
- mv /vastorage/search/lucene/kablink /vastorage/search/lucene/kablink-backup;mkdir /vastorage/search/lucene/kablink;chown wwwrun.www /vastorage/search/lucene/kablink;rcfilr restart
- Perform a Re-Index of Everything
- Go to the Administration Console
- You should be able to log in now
- Choose Search Index in the left window menu list
- Check the box for Re-Index Everything
- This will likely take many hours.
Cause
The kablink directory became corrupt with the unexpected loss of power to the Filr server.