Environment
InfoConnect Desktop (including Pro, or for Unisys) 16.0 and higher
Reflection Desktop (including Pro, for X, for IBM, or for UNIX and OpenVMS) 16.0 and higher
Situation
The following error can occur when attempting to apply a Hotfix, Update, or Service Pack to Reflection or InfoConnect Desktop. "The upgrade patch cannot be installed by the Windows Installer
service because the program to be updated may be missing, or the upgrade
patch may update a different version of the program. Verify that the
program to be upgraded exists on your computer and that you have the
correct upgrade patch."
Resolution
Tell the Windows Installer to which product the patch should
applied, using /package option as shown in the following example:
msiexec.exe /package {ProductCode} /update patch.msp REINSTALL=ALL REINSTALLMODE=omus
where:
- "ProductCode" is the GUID found by the manual inspection of the Microsoft Windows registry keys found at:
HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\UninstallAt the top of this key, search using Edit | Find and use the words "Micro Focus Reflection Desktop" or "Micro Focus InfoConnect Desktop"When you find the value on the right side of the Registry Editor, note the GUID highlighted on the left side of the Registry Editor. This is the value to use as the ProductCode.
- "patch.msp" is the name of the actual MSP or patch file.
As a workaround, totally remove Reflection or InfoConnect Desktop and
reinstall using the default GUID, so the product can be patched and updated without taking the steps above.
Cause
This error message can result if the product's Globally Unique Identifier (GUID) has been changed during install from the default value typically supplied by the product.