OES2018 Pre-Upgrade Check List

  • 7024749
  • 22-Jul-2020
  • 13-Oct-2020

Environment

Open Enterprise Server 2018 (OES 2018) Linux Support Pack 2
Open Enterprise Server 2018 (OES 2018) Linux Support Pack 1
Open Enterprise Server 2018 (OES 2018) Linux

Situation

Steps to perform before upgrading to OES2018.x
Steps to perform before applying a support pack on OES2018.x

Resolution

It is recommended to perform these steps before upgrading to help prevent issues:
 
2) Verify the CA is valid:     iManager -> NetIQ Certificate Server -> Configure Certificate Authority -> Certificates -> Select all the certificates and click Validate.  Then click on the Organization CA and check the Expiration Date.  If the CA is expired or not valid, it should be fixed before upgrading.
 
3) Verify the Server certificates:     Run “openssl x509 -inform pem -noout -text -in /etc/ssl/servercerts/servercert.pem” and check the “Not After” date.  Expired certs should be renewed before upgrading. (https://community.microfocus.com/t5/OES-Tips-Information/Certificate-Re-creation-Script-for-OES2018-OES2015-and-OES11/ta-p/1783799)
 
4) In the /etc/sysconfig/novell directory check the edir file for the current OES version (ie. edir_oes2015_sp1).  If SERVICE_CONFIGURED is not set to "yes", change it to "yes".
 
5) Run “rcnamcd restart” to make sure namcd starts quickly.  If it does not start quickly, it typically indicates a problem with LDAP or a certificate on the nam.conf preferred server.
 
6) Run “ndsrepair –T” to check timesync.  Get all servers in sync before upgrading.
 
7) Run “ndsrepair –E” to check Sync Status.  Any errors should be repaired or at least understood before upgrading.
 
 
Here are a few things to be aware of:
1) Novell Samba is no longer available on OES2018-SP1 and later.  Novell CIFS is still available.
 
2) If upgrading any VMWare VMs, make sure the VM Version is at least 10 and the VM Guest OS is set to SLES12 to help avoid GUI issues.
 
3) If GUI is not starting on OES2018.x with a black screen, try https://support.microfocus.com/kb/doc.php?id=7022871
 
4) If upgrading a GW server, this document might be needed:  https://support.microfocus.com/kb/doc.php?id=7023130
 
5) If upgrading an iPrint server, this document might be needed:  https://support.microfocus.com/kb/doc.php?id=7023593

Feedback service temporarily unavailable. For content questions or problems, please contact Support.