channel-upgrade-oes failed after OES2018SP2 Channel Update

  • 7024701
  • 25-Jun-2020
  • 15-Jul-2020

Environment

Open Enterprise Server 2018 SP2
OES2018SP2

Situation

When follow the OES installation guide and run yast2 channel-upgrade-oes after a wagon upgrade, the upgrade fails with an SAS error.
Further in the ndsd log, similar error messages as below can be seen
SecurityInstall: Error from pkiInstallCreatePKIObjects (ccode = -601; retval = -4). 
An error occurred while configuring product SAS. Error description no such entry.-601 
NDSIInstallDSProduct: Returning -601.
DHModuleInit_dsi: Returning -601.
Module dsi is not loaded

Resolution

A workaround package is available from bug 1171978 

Cause

In some customers' environment, there were no EC certificates but in the upgrade code, the EC objects were also trying to get upgraded and hence it failed.

Feedback service temporarily unavailable. For content questions or problems, please contact Support.