Emails are not being sent for a Password Expiration Notification Job

  • 7024676
  • 09-Jun-2020
  • 09-Jun-2020

Environment

Identity Manager 4.5
Identity Manager Engine Password Expiration Notification Job

Situation

When running a Password Expiration Notification Job emails are not being sent to the users with expiring passwords.
A trace of the job shows the following error.

[05/24/20 01:00:02.699]:MyCollege Password Expiry Notification JT:: Password expires in 14 days
[05/24/20 01:00:02.699]:MyCollege Password Expiry Notification JT:: Sending email to user@mycollege.com
[05/24/20 01:00:02.701]:MyCollege Password Expiry Notification JT:
Job Intermediate Result -------------------
     Job:     \My-TREE\system\driverset1\MyCollege Password Expiry Notification
     Status:  Error
     Object:   \My-TREE\data\users\User1

No additional error is seen in the Password Expiration Job log or driver set trace


Resolution

Make sure you have credentials specified in the Authenticate to sever using credentials: section of the Email Server Options for the email server you are using to send out emails, along with the same password specified for the Email server password on the properties of the Password Expiration notification job





Cause

Missing authentication credentials for email server in the email server options (default notification collection object) and in the properties of the job.