Environment
Identity Manager 4.8
Identity Manager Driver - Active Directory
Identity Manager Driver - Loopback
Identity Manager Driver - Active Directory
Identity Manager Driver - Loopback
Situation
When attempting to start a Loopback driver, the following error is received in driver trace log (level 3)
Message: Code(-9010) An exception occurred: com.microfocus.database.DBException: createOrOpenMap:RetCode:49215
at com.microfocus.database.zoomdb.jni.MapInterface.createOrOpenMap(Native Method)at com.microfocus.database.zoomdb.hashmap.HashMapImpl.mapCreateOrOpen(Unknown Source)
at com.microfocus.database.zoomdb.map.MapImpl.open(Unknown Source)
at com.microfocus.database.zoomdb.map.MapHandler.open(Unknown Source)
at com.microfocus.database.zoomdb.HashMapMakerImpl.make(Unknown Source)
at com.novell.nds.dirxml.engine.WorkManager.openBTree(WorkManager.java:132)
at com.novell.nds.dirxml.engine.WorkManager.initializeDB(WorkManager.java:110)
at com.novell.nds.dirxml.engine.WorkManager.handleIt(WorkManager.java:629)
at com.novell.nds.dirxml.engine.WorkManager.<init>(WorkManager.java:87)
at com.novell.nds.dirxml.engine.Driver.startShim(Driver.java:1717)
at com.novell.nds.dirxml.engine.Driver.initialize(Driver.java:329)
at com.novell.nds.dirxml.engine.Driver.<init>(Driver.java:295)
at com.novell.nds.dirxml.engine.DriverEntry.run(DriverEntry.java:626)
at java.lang.Thread.run(Thread.java:748)
Resolution
Resetting the driver cache files (.TAO) allowed the driver to start.
1. Edit the properties of the driver, disable the driver and save.
2. Edit the properties of the driver, enable the driver (check the box to "Do not automatically synchronize the driver.") and save.
3. Attempt to start the driver.
Cause
Corruption in the cache file. (.TAO file)