O365 Apps on Windows Client fails with Access Manager (script error)

  • 7024525
  • 02-Apr-2020
  • 30-Apr-2020

Environment

  • Access Manager 4.5

Situation

  • NAM is configured as identity provider with O365. The O365 apps running on widows machine fails when redirected to Access Manager. User can see multiple scripts error and if user proceed either using yes or no, finally a blank page is seen on the browser.

Resolution

  • change into folder: "/opt/novell/nam/idp/webapps/nidp/javascript"
  • cp jquery.min.js jquery_new.min.js
  • this should result in having two jquery files:
    • jquery_old.min.js -> jquery version compatible with IE7 v1.12.4
    • jquery_new.min.js -> new jquery v3.4.1
    • (IE7 is very older version of browser and doesn’t work with this)

  • check whether login pages are customized or not

    • NAM standard login page:

      • change into folder: "/opt/novell/nam/idp/webapps/nidp/jsp"

      • search for:
        "<script type="text/javascript" src="<%=request.getContextPath()%>/javascript/jquery.min.js">"


      •  and replace it with:
        <!--<script type="text/javascript" src="<%=request.getContextPath()%>/javascript/jquery.min.js"></script>-->


        <!--[if lt IE 8]>

            <script type="text/javascript" src="<%=request.getContextPath()%>/javascript/jquery_old.min.js">
            </script>

        <![endif]-->


        <!--[if gte IE 8]>

            <script type="text/javascript" src="<%=request.getContextPath()%>/javascript/jquery_new.min.js">

             </script>

        <![endif]-->


        <!--[if !IE]>

            <!-->

            <script type="text/javascript" src="<%=request.getContextPath()%>/javascript/jquery_new.min.js">

            </script>

            <!-->

        <![endif]-->
  • Custom login pages:

    • Find the entry where the jquery.min.js is called and replace with:
      <!--<script type="text/javascript" src="<%=request.getContextPath()%>/javascript/jquery.min.js">
      </script>-->

      <!--[if lt IE 8]>
          <script type="text/javascript" src="<%=request.getContextPath()%>/javascript/jquery_old.min.js"></script>
       <![endif]-->

       <!--[if gte IE 8]>
           <script type="text/javascript" src="<%=request.getContextPath()%>/javascript/jquery_new.min.js"></script>
        <![endif]-->

        <!--[if !IE]>
            <!--><script type="text/javascript" src="<%=request.getContextPath()%>/javascript/jquery_new.min.js"></script><!-->
        <![endif]-->

  •  Access the team or other o365 app and the issue should be resolved.

Cause

It is not a NAM issue as the Microsoft decided to use internal browser as IE7 for team and other application. IE7 is not compatible with the latest jquery(3.x) and hence throwing the exception.