Environment
Micro Focus iPrint Appliance 4.0
Situation
When attempting to register a newly deployed iPrint Appliance 4.0 for Online Updates the following error is returned:
RPC Communication Error
An error occurred while communicating with the server, would you like to see the details?
Clicking Yes returns:
com.novell.admin.common.server.rpc.beans.RpcException: Error: /usr/bin/suse_register -E failed with a return code of 12
Resolution
Check for the existence of the /etc/sysconfig/clock file. If it does not exist, do one of the following:
1. (Preferred)
Login in as vaadmin to the iPrint Appliance Management Console (https://<IP address or DNS name>:9443>)
2. Click on the Time icon and make some change
to the time zone, then change it back. This should trigger the creation of the
clock file. When that file exists, retry the online update
registration.
OR
Manually create the /etc/sysconfig/clock file with contents such as:
TIMEZONE="America/Denver"
DEFAULT_TIMEZONE="America/Denver"
Adjust the timezone as appropriate. The time zone of the appliance can be found in the /etc/sysconfig/novell/NvlVAinit file.
As an example:
CONFIG_VAINIT_TIMEZONE="America/Denver"
Cause
During the deployment/configuration of the iPrint Appliance, the /etc/sysconfig/clock file was not created.
Additional Information
See also: Complete List of TZ database time zones