Environment
GroupWise 18
GroupWise 2014 R2
GroupWise Post Office Agent
GroupWise 2014 R2
GroupWise Post Office Agent
GroupWise Internet Agent
Situation
Steps to confirm IMAP credentials or to test connectivity and functionality of the IMAP protocol
GroupWise no longer allows for clear text login for the IMAP protocol
This means the Telnet utility will not work
Resolution
Openssl can be used to initiate a client connection and login to a the GroupWise IMAP protocol using the following steps.
Open a terminal on a Linux server and enter this command:
openssl s_client -connect yourserver.yourdomain.com:993 -crlf
Note, substitute your server's FQDN or IP address as appropriate. If SSL is not enabled for the IMAP protocol on your GroupWise agent then you will need to change the port from 993 to 143
If the command is successful you will see information about your GW system and certificate information will be exchanged You will then be at an IMAP prompt that looks like this:
* OK [CAPABILITY IMAP4rev1 AUTH=PLAIN AUTH=XGWTRUSTEDAPP UNSELECT XGWEXTENSIONS] GroupWise Server Ready
Now you can issue standard IMAP commands To test a user's credentials enter this command:
a1 login username userpassword
The a1 is simply a command tag and can be anything you choose The username and password should be a GroupWise userID and that user's GroupWise password If they are accepted you will see a return like this:
a1 OK LOGIN completed
This confirms the credentials. Issuing Ctrl - c will terminate the client connection and return you to the terminal prompt
Cause
Enhanced security on the GroupWise IMAP protocol prevents clear text telnet connections