After upgrading to Filr 4.0 and reindexing, some users cannot access their personal files

  • 7024427
  • 12-Feb-2020
  • 12-Feb-2020

Environment

Filr 4

Situation

After upgrading to Filr 4.0 and re-indexing, some users cannot access their personal files.

Resolution

First, verify that you are encountering the problem described. On the Filr appliance, examine the /var/opt/novell/tomcat-filr/logs/appserver.log for entries such as:

2019-11-13 16:28:19,594 INFO [https-openssl-nio-8443-exec-15-(3-1573684099182)] [kablink] [org.kablink.teaming.module.workspace.impl.DefaultWorkspaceCoreProcessor] - Identified 1587 binders to index within the branch [/Home Workspace/Personal Workspaces/John Doe (jdoe)] (id=4120)

2019-11-13 16:28:19,671 ERROR [https-openssl-nio-8443-exec-15-(3-1573684099182)] [kablink] [org.kablink.teaming.module.binder.impl.BinderModuleImpl] - Error in index helper

org.springframework.orm.hibernate3.HibernateObjectRetrievalFailureException: No row with the given identifier exists: [org.kablink.teaming.domain.Binder#1156673]; nested exception is org.hibernate.ObjectNotFoundException: No row with the given identifier exists: [org.kablink.teaming.domain.Binder#1156673]

Here, we see user John Doe has files with identifier 1156673, having failed indexing with the error "No row with the given identifier exists". 

Open a terminal on the database server and run this query (substituting the ID mentioned in your appserver.log file):

select * from SS_Forums where id=1156673; 

If the query returns empty result, check if there are any folders associated with it by running the following query.

select * from SS_Forums where parentBinder=1156673 or topFolder=1156673;

The result returned by this query are the orphaned entries.

Users for whom the indexing has failed in this manner have orphaned files under the home directory. In this case, there are folders with a parent folder entry which does not exist. Folders which have the problem may have another entry with the correct parent folder.

To resolve the problem, it is necessary to manually remove the orphaned entries from the database. For each user with the problem, as seen in the errors recorded in the appserver.log, follow these steps:

1. Mark the folders with the wrong parent, and its sub folders, as deleted. Use this command:

select * from SS_Forums where topFolder=1156673;

This query will return the folders and sub folders under the orphaned folder. Verify that the rows returned have an old modification date. If there are not many folders mark the bad entries for deletion, using this command for each folder:

update SS_Forums set deleted=true where id=<ids of the folders listed in the above queries>;

Or, if there are too many to conveniently do this individually for each folder, use the following command to find all the rows and mark them for deletion:

update SS_Forums set deleted=true where topFolder=1156673;

2. Trigger a re-index of the affected users workspaces and net folders, or simply choose the "reindex everything" option. The is found in the Filr 8443 Administration console > Search Index > Index.

After taking the above steps, the problem should be resolved.

Note: Do not run these steps without proper analysis of the logs, as it may have adverse effects in the Filr environment. Contact NTS if any of the symptoms mentioned above are seen.

Cause

The indexing operation has failed, leaving orphaned files under the home directory. In this case, there are folders with a parent folder entry which does not exist. Folders which have the problem may have another entry with the correct parent folder.