IDM 4.7 - Send eMail from Template fails with: Couldn't send email: java.net.SocketException: Connection closed by remote host

  • 7024380
  • 22-Jan-2020
  • 27-Jan-2020

Environment

Identity Manager 4.7
Identity Manager Driver - AzureAD
Identity Manager Driver - Office 365
Identity Manager Driver - Loopback

Situation

When attempting to do a Send eMail from Template (  do-send-email-from-template ), the following error is received.

DirXML Log Event -------------------
     Driver:   \tree\Org\DriverSet\AzureAD
     Channel:  Subscriber
     Object:   \tree\Org\Users\user6
     Status:   Error
     Message:  Code(-9195) Error in vnd.nds.stream://tree/Org/DriverSet/AzureAD/Subscriber/Setup+email+address+for+non-adminitted+applicants#XmlData:47 : Couldn't send email: java.net.SocketException: Connection closed by remote host

This issue has also been seen reporting the following error back:

DirXML Log Event -------------------
     Driver:    \tree\Org\DriverSet\Business Logic
     Channel:  Subscriber
     Status:   Error
     Message:  Code(-9195) Error in vnd.nds.stream://tree/Org/DriverSet/Business+Logic/Subscriber/TestEmail#XmlData:8 : Couldn't send email: com.sun.mail.smtp.SMTPSendFailedException: 530 5.7.57 SMTP; Client was not authenticated to send anonymous mail during MAIL FROM [server.outlook.com]

Resolution

Specify the password for the user in the server email seeings, that is being used to authenticate into the SMTP server, in the Send eMail from Template action, Specify Password field.

Cause

The Send eMail from Template action is not reading the password for the SMTP connection from the email server settings (default notification collection object) in eDirectory.   This issue has been reported to engineering.