Environment
Self Service Password Reset 4.4
Situation
After setting reCAPTCHA to version 3, user is not able to login to SSPR. Error appears on the SSPR login page before user enters username or password.
Steps:
Configure the 'reCAPTCHA version 3' (Config Editor -> Settings -> Captcha),
Set up the reCaptcha settings on the Google side (google.com/recaptcha/admin/create), select reCAPTCHA v3 and then copy/paste the keys into SSPR under Settings -> Captcha.
Save these settings in configuration editor and wait for SSPR to restart. The following error is displayed on the SSPR login page as soon as the page comes up (i.e. before user can enter anything):
"ERROR for site owner: Invalid key type"
Resolution
Change the 'reCAPTCHA Mode' in SSPR to 'reCAPTCHA version 3 - Invisible' (rather than 'reCAPTCHA version 3') and the reCAPTCHA functionality works without issue.
Cause
Currently under investigation by Engineering