iManager returns 503 error to Browser

  • 7024347
  • 17-Dec-2019
  • 17-Dec-2019

Environment

eDirectory
Open Enterprise Server 11 (OES 11) Linux

Situation

After performing some work -- adding replicas to other servers and moving the CA to another host, trying to access iManager on the original server would return a 503 error.  The following was also observed:
  • rcnovell-tomcat6 status would return "dead"
  • restarting tomcat, rcnovell-tomcat6 start, would yield a message:
        lock file found but no process running for pid XXXX, continuing
    where XXXX is a process ID number.

Resolution

  • stop tomcat (rcnovell-tomcat6 stop)
  • remove the file /var/run/novell-tomcat6.pid
  • start tomcat (rcnovell-tomcat6 start)

Cause

The tomcat PID file was stuck and needed to be manually removed.

Additional Information

The following trouble shooting steps were taken:
- restarted tomcat (rcnovell-tomcat6 restart)