iPrint Appliance 4.x: Reading list of printers returns RPC error

  • 7024315
  • 04-Dec-2019
  • 28-May-2021

Environment

Micro Focus iPrint Appliance 4.x
Micro Focus iPrint Appliance 3.x

Situation

  • RPC error is returned when trying to pull up the list of printers within the Management ConsoleRequest SERVER_ERROR bad status code 0x501 error is returned when attempting to manage the Print Manager via iManager.
  • Mobile printing is not working
  • Desktop printing is working
  • One or more printers have been enabled for AirPrint printing.The /var/log/apache2/error_log file shows:
[DATE] [:error] [pid XXXX] Error occurred while fetching licensing information.
[DATE] [:error] [pid XXXX] ParseAndProcessIPPRequest : No valid license available
[DATE] [:warn]  [pid XXXX] IPP Operation error=SRVR_ERR_OPERATION_NOT_SUPP, operation=Get Printer Attributes
[DATE] [:error] [pid XXXX] REST call failed. HTTP Status Code: 404
[DATE] [:error] [pid XXXX] Fetching license info failed.
[DATE] [:error] [pid XXXX] Http Code : 404
[DATE] [:error] [pid XXXX] Curl Code : 22

Resolution

Workaround:
Turn off the AirPrint feature on all printers.  However, this cannot be done because of the RPC error within the Management Console.  Micro Focus support can do this for you.  Micro Focus support engineers can access the OrientDB to turn off the AirPrint feature on the printer (or printers). 

Resolution:
Micro Focus engineering is evaluating this problem. They plan to come up with a code update which will prevent this problem from occurring.

Cause

A bug in the code which affects AirPrint printers and submitting large print jobs through AirPrint.