D107 Error on User Database Prevents Mobility Server From Displaying New Messages - User Specific

  • 7024104
  • 06-Sep-2019
  • 06-Sep-2019

Environment

GroupWise 18
GroupWise 2014 R2
GroupWise 2014
GroupWise Mobility Service 2014 R2
GroupWise Mobility Service 18

Situation

Specific users do not receive updates to their phones of any new events in GroupWise.   This includes new or deletion of messages or appointments. 

Resolution

Running a Analyze/Fix of Structure and Contents of the mailbox can restore this functionality, but if that is unsuccessful a Structural Rebuild of the user db may be necessary.

Procedure:

1.  Delete the user from the Mobility Admin
2. From within the GroupWise Admin Console, run the Analyze fix of the user:
  • Locate the user to be worked on
  • Choose Maintenance | Check Structure, Content, Fix Problems, User and Message database | OK
3.  If after recreating the user in the Mobility Admin and the problem is not corrected, then remove the user again and perform a Structural Rebuild of the User. 
  • Locate the user to be worked on
  • Choose Maintenance | Use the Actions drop down selector to choose Stuctural Rebuild | OK
Beware:  Choosing a Structural Rebuild will transfer records from the existing user.db to a new user.db.  If records are damaged, they will not be moved.   Having a good backup is important if a mail is not transferred to the new database.  Also, Quickfinder indexes for that user will be wiped out and will require time to regenerate.  Searches performed by the user will be slower until fully regenerated.

Cause

If the index that tracks new events in the GroupWise mailbox is damaged, it is possible that a SOAP request to retrieve new events will give a D107 error (record request not found).

Snip from a POA log showing this occurring:

00:30:29 635E SOAP command:[getEventsRequest] requested from xxx.xxx.xxx.xxx   User session(userid_of_affected_user) Elapsed Time (0.208)Secs
00:30:29 635E   ReadIndex Database=userm1o.db, Domain=262, Idx=1548, Type=record 060B   App( SOAP )
00:30:29 635E   Requested=256, ReturnedDRNs=123, FirstDRN=57295, BRead=3, RRead=0   App( SOAP )
00:30:29 635E   ReadRecords  Domain 262  DiskId 0 status:[D107]   App( SOAP )
00:30:29 635E SOAP command:[getEventsRequest] requested from xxx.xxx.xxx.xxx   User session(userid_of_affected_user) Elapsed Time (0.211)Secs
00:30:29 635E SOAP Error: Record not found [D107]

In the groupwise-agent.log on the mobility server, an error 53511 will show when doing a getEventsRequest.