GroupWise Client Hangs Intermittently

  • 7024070
  • 20-Aug-2019
  • 18-Nov-2019

Environment

GroupWise 2012
GroupWise 2014
GroupWise 18

Situation

  • GroupWise Client hangs, freezes or pauses for exactly two minutes in caching mode
    • 120 seconds
    • 2 minutes
  • Only GroupWise Client hangs
    • Other applications continue to run without problems
  • After the hang the GroupWise Client continues to run normally
  • Frequency of freezes may be one or two per week or several per day
  • Problem may be accompanied by 820E errors
    • Flaim Error = 0x820e -- Function id = 48, Store Number = 0x1242424
      • Store 1242424 refers to the User Database in Caching Mode

Resolution

Contact the provider of the third party product causing the problem (see Cause, below).

Cause

One specific case was caused by the product Forcepoint Data Loss Prevention (DLP)* but the problem could also potentially be caused by any software which intercepts disk writes, such as anti-virus or endpoint security solutions.  

* See Forcepoint KB 000017690 (a customer login ID is required).

Status

Reported to Engineering

Additional Information

Conventional debugging, collecting of logs and capturing of dump files gave no indication of the cause of the problem due to the low-level at which this type of security software operates.  The only way to establish the cause was to remove (not just disable) applications one-by-one until the problem went away.