Environment
GroupWise Mobility Service 14
GroupWise Mobility Service 14R2
GroupWise Mobility Service 18
GroupWise Mobility Service 18.1.x
Situation
Some attachments synced to mobile device show with an extension of
.txt. These attachments are unviewable on the mobile device. On the
GroupWise client the attachment comes in as expected.
Resolution
Maximum Attachment Size (GroupWise to Device) needs to be
increased.
Steps:
1. Go to Mobility Admin Console
2. Go to the Config Tab > General
3. Modify the "Maximum Attachment Size (GroupWise to Device)"
setting so it fits your needs.
4. Restart Mobility services
5. Test once more. Attachments that meet the attachment size
criteria will display as expected and will no longer have the .txt
extension
Cause
Attachments larger than the allowed Max Attachment Size on
the Mobility server have a .txt extension appeneded on them on
purpose. This is working as designed.
Additional Information
In the GroupWise agent log the following error can be found
when the attachment is larger than the allowed size:
[AttachmentMaxSize] Blocking attachment
(attachmentName.extensiom) size: XXXXX. It is larger than the
maximum attachment size of XXXXXX.