Environment
Micro Focus Open Enterprise Server 2018 SP1 with iPrint
Situation
After applying the May 2019 iPrint OES patch, the authentication to the iPrint ipcon (iPrint Console) tool fails. This happens to iPrint servers which were upgraded from OES 2015 to OES 2018.
Resolution
Paste the following string of commands into a terminal session while logged in as root:
rcnovell-iprint-mobile stop;sh /usr/share/orientdb/bin/config_db.sh;rcnovell-iprint-mobile start
rcnovell-iprint-mobile stop;sh /usr/share/orientdb/bin/config_db.sh;rcnovell-iprint-mobile start
Cause
The orientdb database requires configuration because OES 2018 SP1 (with the May 2019 patch installed) changes the way the iPrint Mobile service interacts with that database. A database configuration script (config_db.sh) automates that configuration. In some upgrade scenarios, that script does not execute.