Missing soft links after system update on Appliance

  • 7023913
  • 04-Jun-2019
  • 29-Oct-2020

Environment

ZENworks Configuration Management
ZENworks Patch Management
ZENworks Endpoint Security Management
ZENworks Full Disk Encryption

Situation

After running system update on Appliance, soft links are lost and the system update will fail.  The ZENworks services have errors and ZCC isn't available.

Resolution

For ZENworks 2017 update 4:  If the system update has not been run yet, confirm if  rpm-4.11.2-16.21.1.x86_64.rpm is installed, and contact Micro Focus Customer Care for a test patch to prevent the problem from occurring.  If the problem is seen already, contact Micro Focus Customer Care for a script to fix the primary server soft links.

For later versions of ZENworks the problem is fixed for appliance.  But in the case where zzenserverroles does not show Appliance role, it may happen again.  Be sure that all Appliances have Appliance role in zzenserverroles.

Cause

rpm-4.11.2-16.21.1.x86_64.rpm which was provided with April security patches caused the links to be deleted.