Unable to login to GroupWise Webaccess 18.1.2 on a SLES12 SP2 / OES2018 NCS cluster

  • 7023819
  • 11-Apr-2019
  • 16-Apr-2019

Environment

GroupWise 18.1.2

Situation

GroupWise 18.1.2 FTF build # 133407 Webaccess installed on a SLES12 SP2 / OES2018 NCS cluster node, when I try to login in any browser, I get the Webaccess Login page , I put my credentials and I get an error after about 80 seconds of waiting :

######################## Error #############################################

  "Bad Gateway!, The proxy server received an invalid response from an upstream server.

   The proxy server could not hangle the request POST /gw/webacc.

   Reason: Error reading from remote server

   If you think this is a server error, please contact the webmaster.

Error 52

  <GroupWise Cluster node hostname>
  Apache

############################################################################

Resolution

This issue has been reported to GroupWise development.

Cause

Unknown as of date of this document.

Additional Information

A packet trace was taken on the Webaccess / POA linux server with :
  
  tcpdump -i any -s0 -w /root/trace.cap .

It revealed that the 3 way tcp/ip handshake between the Webaccess application and the GroupWise POA completed successfully and data was being transferred between the two and then a 38 second delay occurred for an unknown reason then the tcp/ip converstation continued but never completed as the browser error occurred "Error 52 Bad Gateway".

This issue was confirmed and again duplicated on a new OES2018 NCS cluster.