TeamWorks user locked out

  • 7023678
  • 25-Jan-2019
  • 28-Jan-2019

Environment

GroupWise Teamworks

Situation

User is unable to log into TeamWorks receives Authentication Failure error

Even when the correct password is confirmed the error remains.


Resolution

The account will automatically reset after 30 minutes and the user can again log in.  Alternately the user’s password can be changed and the TeamWorks services restarted to allow for immediate access.

Note: It does not matter if the user is local or LDAP sourced.

The Brute Force protection can be turned off if security is not a major concern.

To turn it off:

1.       Access the console of the TeamWorks server

2.       Edit the following file: /opt/novell/esn/apache-tomcat/webapps/ssf/WEB-INF/classes/config/ssf.properties

3.       Find the line in the file that contains “failed.user.authentication.history = true”

4.       Change it to “failed.user.authentication.history = false”

5.       Save the file and restart the TeamWorks services


Cause

The TeamWorks back end contains a Brute Force Protection algorithm.   If a user attempts to log in 5 times with the wrong password then the account is locked. 

The five bad password attempts must be made within any given 30 minute window and can be mixed with successful logins.