InfoConnect Desktop Pro/ InfoConnect Airlines Pro/ Reflection Desktop Freezes or Crashes on Windows 10 Build 1809

  • 7023620
  • 08-Jan-2019
  • 29-Jan-2019

Environment

Reflection Desktop (including Pro,for IBM) 16.1
InfoConnect Airlines Gateway NG 16.1
InfoConnect Airlines Gateway NG 16.0
InfoConnect Desktop (including Pro, for Unisys, for Airlines) 16.1
InfoConnect Desktop (including Pro, for Unisys, for Airlines) 16.0
InfoConnect Desktop Pro for Airlines 16.1
InfoConnect Desktop Pro for Airlines 16.0
Windows 10 Build 1809

Situation

Customers upgrading to Windows 10 Build 1809 may see certain Micro Focus products freeze or become unresponsive when attempting to do the following:
  • Print Screen dialog hangs in a terminal session
  • Printer session hangs on load
  • EML [Express Macro Language] macro editor or macro can crash with an Exception Error

Resolution

On Tuesday, January 22, 2019, Microsoft released an update for Windows 10 Build 1809.

          2019-01 Cumulative Update for Windows 10 Version 1809 (both x86 and x64)  KB4476976

https://support.microsoft.com/en-us/help/4476976/windows-10-update-kb4476976

This update has been confirmed to resolve the issues documented in this Technical Information Document.

Install this update

To download and install this update, go to Settings > Update & Security > Windows Update and select Check for updates.

To get the stand-alone package for this update, go to the Microsoft Update Catalog website.

Cause

With the initial release of Microsoft Windows 10 Build 1809, Microsoft made changes to some of their legacy API calls. These changes resulted in an exception error being encountered when these legacy API calls were made inside of certain Micro Focus products. Microsoft has addressed the issues caused by this change in 019-01 Cumulative Update for Windows 10 Version 1809 (both x86 and x64) Microsoft KB4476976.

Status

Top Issue