TLS 1.2 Support for AppManager Modules

  • 7023595
  • 17-Dec-2018
  • 29-Jan-2019

Environment

AppManager Enterprise 9.2

AppManager Enterprise 9.1

TLS 1.2 Support Required

Situation

TLS 1.2 support has been incorporated into AppManager 9.5. As far as modules are concerned, we have added TLS 1.2 support for the following most frequently used modules. Please refer to the table below for the list of modules and their corresponding version with TLS 1.2 support. If you require TLS 1.2 support and are running AppManager 9.1 or 9.2 you will need to perform some additional steps as outlined below:

 

AppManager Module

Short Name

Build Version

HotFix Version

1

WINOS

WinOS

8.1.170.0

8.1.0.2

2

Microsoft SQLServer

SQLServer

8.2.83.0

8.2.0.3

3

AMHealth

AMHealth

8.2.134.0

8.2.0.5

4

Hardware

Hardware

8.2.51.0

8.2.0.1

5

VMWare (Vsphere)

VMWare

8.1.68.0

8.1.0.2

6

WebRT

Web-RT

7.4.58.0

7.4.0.4

7

Exchange

Exchange2007

7.6.156.0

7.6.0.2

8

IIS

IIS

7.4.70.0

7.4.0.1

9

Active Directory

AD

7.1.92.0

7.1.0.1

10

Win RT

Win-RT7

7.7.164.0

7.7.0.1

11

MSCS

MSCS

7.2.78.0

7.2.0.5

12

DELL Open Manage Hardware

Dell

7.3.88.0

7.3.0.9

13

HP CIM

CIM

7.4.115.0

7.4.0.10

14

XenDesktop

XenDesktop

8.1.22.0

8.1.0.1

15

Network Device

NetworkDevice

7.6.105.0

7.6.0.4

16

SNMP

SNMP

7.5.68.0

7.5.0.2

17

SNMP Traps

SNMPTraps

8.1.33.0

8.1.0.3

18

CallDataAnalysis

CallDataAnalysis

7.5.113.0

7.5.0.2

19

CiscoCM

CiscoCM

7.6.70.0

7.6.0.0


Resolution

  1. Download AM_TLS1.2_Update.zip package from our FTP site: ftp://ftp.novell.com/outgoing/bug7023595/AM_TLS1.2_Update.zip. This package must be downloaded and installed on the machines where the consoles (Operator Console and Control Center) and report agents are installed.
  2. Extract the AM_TLS1.2_Update.zip file.
  3. Open a command prompt as Administrator.
  4. Change directory to where you extract the AM_TLS1.2_Update files.
  5. Run the following command:

    PowerShell.exe -ExecutionPolicy Bypass –File ExtensionsInstaller.ps1

Same procedure is applicable for all Operator console, Control Center console and report agent machines. The script takes care of installing only the required files for each type of component on each machine. Contact Technical Support if you have any additional questions.

Cause

Operator console and Control Center console uses some .VBS files (where TLS 1.2 changes are made), that are not packaged with the installers. Instead, they are packaged with module installers and the AppManager "complete" installer. We are unable to release an updated complete installer for version 9.1 and 9.2. We can only deliver updates for separate components; therefore, the decision was made to deploy these files using the aforementioned script.