Environment
GroupWise Mobility Service 18
GroupWise Mobility Service 2014 R2
GroupWise Mobility Service 2014 R2
Situation
User recently added shows Failed sync status in GroupWise Mobility WebAdmin
The /var/log/datasync/connectors/groupwise-agent.log reports the following:
User <userID> NOT added to the GWC cache because we could not get the PABs.
Failed to find user <userID> in cache or failed GroupWise login! Can not complete this users configurations without logging in.
Problem caching address book list for user <userID>. User will not be added to the GWC cache.
The /var/log/datasync/connectors/groupwise-agent.log reports the following:
User <userID> NOT added to the GWC cache because we could not get the PABs.
Failed to find user <userID> in cache or failed GroupWise login! Can not complete this users configurations without logging in.
Problem caching address book list for user <userID>. User will not be added to the GWC cache.
Resolution
User has a Personal Address Book with extended ascii characters in it.
Steps to resolve:
1. Use dsapp to force remove user.
Download dsapp from: ftp://ftp.novell.com/outgoing.dsapp.zip
Unzip dsapp.zip
rpm -ivh dsapp-<version>.noarch
In dsapp select: User Issues | Remove & reinitialize user options | Force remove user/group
2. Delete/remove personal address book with special characters.
3. Readd the user in the GroupWise Mobility WebAdmin console
Cause
Extended ascii characters in personal address books