Environment
iPrint for Linux Open Enterprise Server
iPrint Appliance 1.x, 2.x, 3.x
Situation
Trying to manage iPrint objects in iManager returns an "Insufficient Rights" message even when logged in as admin.
Resolution
Restart the ipsmd process.
- Open a putty session or terminal to the iPrint server or Appliance and logged in as root type:
rcnovell-ipsmd restart
Cause
When the ipsmd process first loads, it reads and caches eDirectory rights data. In some rare and random cases, this cached data gets changed in way that when attempting to manage iPrint objects in iManager, the iPrint management tools are unable to verify rights. Restarting the ipsmd process causes the eDirectory rights data to be refreshed.
Additional Information
Restarting the ipsmd process will temporarily affect printing. Typically the restart process takes no more than a minute. However, depending on the environment, it could take longer.