Privileged Account Manager 3.6
Privileged Account Manager 3.5
SUSE Linux Enterprise Server 12
During a brand new install of PAM on SLES 12, the following error occurs:
# rpm -ihv netiq-npam-manager-3.5.0-linux-2.6-x86_64.rpm
error: Failed dependencies:
lsb >= 3.0 is needed by netiq-npam-manager-3.5.0-linux-2.6-x86_64.rpm
- Please resolve this dependency by upgrading lsb to >= 3.0.
From a terminal window on the server, please enter the following command:
zypper in lsb
- Verify lsb is >= 3.0:
rpm -qa | grep lsb
- Then proceed with the PAM install again.
SLES 12 or other Linux server has a version of lsb < 3.0 where PAM requires >= 3.0.
StatusReported to Engineering
The following will display the version of lsb installed on the OS:
# rpm -qa | grep lsb
The following steps detail the GUI approach to upgrading this dependency:
- Open YaST Software Management
- Search for 'lsb'
- Select what is available >= 3.0, in this case: 'lsb5 - Linux Standard Base'
- Click Accept to Install
- Click Continue (automatic dependency resolutions)
- Click Finish