Failed dependencies during initial PAM install on sles 12 (lsb >= 3.0)

  • 7023285
  • 17-Aug-2018
  • 31-Jan-2020

Environment

Privileged Account Manager 3.6
Privileged Account Manager 3.5
SUSE Linux Enterprise Server 12

Situation

During a brand new install of PAM on SLES 12, the following error occurs:

# rpm -ihv netiq-npam-manager-3.5.0-linux-2.6-x86_64.rpm
error: Failed dependencies:
    lsb >= 3.0 is needed by netiq-npam-manager-3.5.0-linux-2.6-x86_64.rpm

Resolution

  1. Please resolve this dependency by upgrading lsb to >= 3.0.
    From a terminal window on the server, please enter the following command:
    zypper in lsb

  2. Verify lsb is >= 3.0:
    rpm -qa | grep lsb

  3. Then proceed with the PAM install again.

Cause

SLES 12 or other Linux server has a version of lsb < 3.0 where PAM requires >= 3.0.

Status

Reported to Engineering

Additional Information

The following will display the version of lsb installed on the OS:
# rpm -qa | grep lsb
lsb-release-2.0-28.1.noarch

The following steps detail the GUI approach to upgrading this dependency:
  1. Open YaST Software Management
  2. Search for 'lsb'
  3. Select what is available >= 3.0, in this case: 'lsb5 - Linux Standard Base'
  4. Click Accept to Install
  5. Click Continue (automatic dependency resolutions)
  6. Click Finish

Feedback service temporarily unavailable. For content questions or problems, please contact Support.