The GroupWise 18.0.1 GWIA (GroupWise Internet Agent) fails to connect to the GroupWise Secure Messaging Gateway (SMG)

  • 7023262
  • 13-Aug-2018
  • 13-Aug-2018

Environment


GWAVA (Secure Messaging Gateway) 7
GroupWise 18

Situation

The GroupWise 18.0.1 GWIA (GroupWise Internet Agent) fails to connect to the GroupWise Secure Messaging Gateway

Symptoms: 

1.  GroupWise users would experience "pending" status for all sent messages to the internet.

2.  Looking at the GWIA log would show the errors :

  "Attempting to connect to <SMG hostname>"

  "Send Failure: 420 TCP read error"

Resolution

To correct this issue make sure you have an SMTP banner configured in the SMG "System Administration" web console :

  a.  "Module Management"
  b.  Interfaces
  c.  SMTP "Interface Manager"
  d.  Expand "SMTP Interface"
  e.  Expand "Protocol"
  f.  Type an appropriate SMTP banner in this list box, like "GroupWise SMG Server"
  g.  Click on the SAVE icon in the upper right

Cause

A network packet trace was taken on the GroupWise GWIA server and it could be seen
that after the successful "TCP 3-Way Handshake" (from the GWIA to the SMG servers) that the SMG box was responding with an SMTP 220 with no smtp banner after the 220 response.  Also when you attempt to "telnet" an e-mail directly to the SMG server, it would also respond with a 220 and no banner.  The GWIA does not like this type of response.

Additional Information

 When the SMG is disabled and the GWIA is allowed to send directly to the internet, the e-mail then sends fine, indicating a "possible" SMG configuration issue.