Environment
GroupWise 2014 R2
GroupWise 18
GroupWise 18
Situation
In some cases, customers are unable to install the GroupWise
client at all on Windows 10. In some cases, the client will
install but then will error out when trying to start, saying that
it was not installed correctly. In other cases, the default
mail client is not set in Windows 10 so users are unable to do a
SendTo function in any application and select GroupWise as the
application.
The error can be : "Word couldn't sent mail because of MAPI failure: "Unspecified error""
In all of these cases, Outlook has been installed on the
workstation along with GroupWise
Resolution
Microsoft is sometimes installing a virtualised version of Outlook.
This Outlook installs its own mapi and sets itself as default.
There is no way to change the default because the registry is
a virtualized one that can only be access by Outlook.
The workaround we have found for this is deleting the following files:
c:\Windows\SysWOW64\MMGA*.dll
This seems to cause everything to fallback to the standard mode of operation.
Deleting the files from there is not an easy task. First you need to change the owner of the files to yourself. Then give yourself full control of the files and finally you can rename/delete them.
We haven't found a better work around so far or anything we can do on the GroupWise side to fix it but our engineering team is still investigating it.
The workaround we have found for this is deleting the following files:
c:\Windows\SysWOW64\MMGA*.dll
This seems to cause everything to fallback to the standard mode of operation.
Deleting the files from there is not an easy task. First you need to change the owner of the files to yourself. Then give yourself full control of the files and finally you can rename/delete them.
We haven't found a better work around so far or anything we can do on the GroupWise side to fix it but our engineering team is still investigating it.
A batch file using this information can be written to make this easier:
takeown /F c:\Windows\SysWOW64\mmgaclient.dll
takeown /F c:\Windows\SysWOW64\mmgaproxystub.dll
takeown /F c:\Windows\SysWOW64\mmgaserver.exe
icacls "c:\Windows\SysWOW64\mmgaclient.dll" /T /C /grant
administrators:F System:F everyone:F
icacls "c:\Windows\SysWOW64\mmgaproxystub.dll" /T /C /grant
administrators:F System:F everyone:F
icacls "c:\Windows\SysWOW64\mmgaserver.exe" /T /C /grant
administrators:F System:F everyone:F
del /F /Q c:\Windows\SysWOW64\mmgaclient.dll
del /F /Q c:\Windows\SysWOW64\mmgaproxystub.dll
del /F /Q c:\Windows\SysWOW64\mmgaserver.exe
Cause
A change to the registry and to Outlook made by Microsoft.
Additional Information
New Information: This issue is fixed in GroupWise 18.0.x FTF builds 132196 or higher.