REST driver times out on the subsciber channel on startup.

  • 7023199
  • 23-Jul-2018
  • 01-Aug-2018

Environment

Identity Manager 4.6
REST driver v.1.0.1.0

Situation

An IDM REST driver configured to connect to a REST interface would take a long time to start communicating on the subscriber channel. If it did not start with configured timeout, the following error was seen and the driver would terminate

07/17/18 13:46:23.445]:REST-SVP2 ST:        GroupIDM2CSH (SVP2): sub-execute
[07/17/18 13:46:23.445]:REST-SVP2 ST:        GroupIDM2CSH (SVP2): queryHandler
[07/17/18 13:46:23.445]:REST-SVP2 ST:        GroupIDM2CSH (SVP2): queryHandler: class-name  == 'User'
[07/17/18 13:46:23.446]:REST-SVP2 ST:        GroupIDM2CSH (SVP2): Query: preparing POST to https://demorestapp.lab.com.au/idaas/im/scim/v1/Users/.search
[07/17/18 13:46:23.446]:REST-SVP2 ST:        GroupIDM2CSH (SVP2): Setting the following HTTP request properties:
Authorization: <content suppressed>
[07/17/18 13:46:23.447]:REST-SVP2 ST:        GroupIDM2CSH (SVP2):  content-type:application/scim+json
[07/17/18 13:51:23.578]:REST-SVP2 ST:        SubscriptionShim.execute() returned:
[07/17/18 13:51:23.579]:REST-SVP2 ST:
<nds dtdversion="3.0">
          <source>
                 <product build="20170208_1048" version="1.0.1.0">Identity Manager REST Driver</product>
                <contact>NetIQ Corporation.</contact>
        </source>
        <output>
              <status event-id="0" level="fatal" type="app-authentication">IOException: Read timed out</status>
       </output>
</nds>

The default timeout was increased from 5 to 20 minutes and the driver would eventually start. Once the first request was sent, subsequent requests were very quick and all well until the driver needed to be restarted.

No other errors were seen in the IDM trace.

Resolution

A packet trace showed that at startup IDM was actually doing a GET to the base URL: idaas/im/scim/v1 and the application would not respond.
This was not seen in the IDM trace.
Reproducing the GET command with curl would reproduce the behaviour.

Changing the base URL from:
https://demorestapp.lab.com.au/idaas/im/scim/v1/
to
https://demorestapp.lab.com.au/idaas/im/scim/

resolved the problem as the latter URL responds with an error immediately rather than hanging.
In this case it was also necessary to update each of the class API paths to prefix with ‘v1/’ so requests go to the correct API.


Cause

This was a configuration error that was difficult to detect because the driver call to the validate the base URL does not appear in the logs.
This has been reported to engineering so that this call will be seen at a higher trace level.

Status

Reported to Engineering