GroupWise Disaster Recovery (Reload for GroupWise) Jobs Do Not Finish Syncing To Paired Server - Locked Job

  • 7023198
  • 23-Jul-2018
  • 12-Mar-2019

Environment

GroupWise Disaster Recovery (Reload for GroupWise) 

Situation

While running GroupWise Disaster Recovery (GWDR) using the collector model, the job appears to run fine, yet when running the sync process, sending the data to the Paired GWDR Server, the job locks and doesn't finish. This causes the job on the GWDR Paired server to not start, and the backup does not finish completely. 

Resolution

This is causes when the sync job becomes locked, and the process has been told to halt the job. When looking in the agent.log the line will show the following:

[I] DATE: Fri_Apr_13 TIME: 11:43:46 PROFILE: PO - [GRE_PO_SYNC] - ... Then remove this file: /reloadbackup/po/temp/sync/gre_sync_lock.bin

[I] DATE: Fri_Apr_13 TIME: 11:43:48 PROFILE: PO - [GRE_PO_SYNC] - BLOBS Thread #2 of 2 : Beginning Processing Directory #240 named: fdf2

Navigate to the "profile location/profile/temp/sync" directory that shows in the log: "/reloadbackup/po/temp/sync" and delete the gre_sync_lock.bin. 

Let the job finish, or stop the current job and start the job again. This will reset the lock, and the sync process will continue from there. On subsequent jobs the job will not lock as well. 


Cause

After the update to GroupWise Disaster Recovery 18, the collector sync process has issues initially. Clearing the lock resolves the problem.