The CSR file generated from iPrint Management Console is invalid

  • 7023116
  • 21-Jun-2018
  • 21-Jun-2018

Environment

Micro Focus iPrint Appliance 3.1.1

Situation

The Management Console in the iPrint Appliance 3.1.1 generates an invalid Certificate Signing Request (CSR) file.  There is nothing to indicate an invalid CSR file has been generated until you submit the CSR to a Certificate Authority who will report the CSR file is corrupt or invalid.

Resolution

To resolve this issue you will need to use OpenSSL. 
  1. In a putty session or terminal on the iPrint Appliance type:
    • cd /tmpmkdir openssl
    • cd openssl
    • openssl genrsa -out /tmp/openssl/iprint31.mobile.com.key 2048
    • openssl req -new -sha256 -key /tmp/openssl/iprint31.mobile.com.key -out /tmp/openssl/iprint31.mobile.com.csr
      • You will be prompted to answer a number of questions specific to your environment.  After answering the questions, the .CSR file will be generated.
  2. Verify the CSR using this command:
    • openssl req -noout -text -in /tmp/openssl/iprint31.mobile.com.csr  
  3. You should now be able to submit the CSR to the Certificate Authority (CA) and then upload the required files received by the CA through the Management Console following:
    • Follow the steps within the documentation, starting with step #6. 

Cause

A defect in the CSR generation process.