SSPR users do no receive email when using Forgotten Password

  • 7022891
  • 25-Apr-2018
  • 26-Apr-2018

Environment

Self Service Password Reset
SSPR 4.2

Situation

Users do not receive email when changing password through SSPR forgotten password module. 
Email with token not sent from SSPR Forgotten Password module

Resolution

Using SSPR Configuration Manger, change the "TO"  address in Settings ⇨ Email ⇨ Email Templates, "Forgotten Password Verification Email" to the default value of  @User:Email@ 

Then Define the setting for user email in LDAP ⇨ LDAP Directories ⇨ default ⇨ User Attributes, “User Email Attribute”  to point to the actual email attribute in the directory, e.g. "myPersonalEmail."

This way @User:Email@ will resolve to the value of myPersonalEmail.


Alternatively, set the "TO" address to @LDAP:myPersonalEmail@

Cause

Invalid “TO” address in the "forgotten password verification email template.  

Settings ⇨ Email ⇨ Email Templates,  "Forgotten Password Verification Email"  was set to 
@User:myPersonalEmail@