After upgrade to OES 2018 GUI is not starting ( black screen).

  • 7022871
  • 20-Apr-2018
  • 14-May-2018

Environment


Open Enterprise Server 2018 (OES 2018) Linux

Situation

Following an upgrade from OES 2015 SP1 on SLES11 SP4 forward OES 2018 no GUI is available.


The upgrade is finished with no error.
after reboot, the server is in an unstable state - only a black screen is shown.

iManager, SSH and the rest of the configured services are running fine.

The following is seen in the messages:

[Wed Jan  3 10:17:38 2018] pool[4123]: segfault at 55 ip 0000000000000055 sp 00007ff5e3fee458 error 14 in gnome-shell[400000+4000]

Resolution

As root run:

zypper packages --orphaned

that lists the packages not listed in any repository - for your case it should list "libcroco" as one of them.

zypper remove --clean-deps libcroco

ldconfig

systemctl isolate multi-user.target

systemctl isolate graphical.target

Cause

This was found to be due to a problem with old packages from previous SLES
releases not being cleaned up(or upgraded and still residing on the system)
after completing an upgrade.

This can be found by running the following after the upgrade(OES 2018/SLES 12
used as an example):
rpm -qa --queryformat "%-35{NAME} %-35{DISTRIBUTION} %{VERSION}-%{RELEASE}\n" |
sort -k 1,2 -t " " -i|grep SUSE\ Linux|grep -v "SUSE Linux Enterprise 12"

The above lists packages that should be removed if not specifically needed and
could cause problems down the line, especially with libraries.