GMS 18 install/upgrade fails "Invalid Host Name"

  • 7022825
  • 09-Apr-2018
  • 09-Apr-2018

Environment


GroupWise Mobility Service 18

Situation

During an install/upgrade of GMS 18 enter the host name of my GroupWise domain server, admin port number, and GroupWise admin credentials, it fails with a host name mismatch.

Resolution

This can happen if the server hosting your GroupWise domain has undergone a server name or IP address change at some point.  The GMS installation validates the GroupWise Admin certificate on that server.  To check what host name and IP address is in the GroupWise Admin certificate do the following:

  1. On the server hosting the GroupWise domain go to /opt/novell/groupwise/certificates/<longhashdir>
  2. Find your domain certificate - admin.domainname.crt
  3. Run the following command:  openssl x509 -text -in admin.domainname.crt | grep DNS
  4. This shows the subject alternative name in the certificate, for example:  DNS:grpwise.test.com IP Address:10.10.10.10
  5. If the DNS name or IP address reflected in the GroupWise Admin certificate does not match the current host name and IP address of the GroupWise domain server you need to fix the certificate using the gwadminutil utility.

Sample command:  gwadminutil certinst –db /path/to/dom –ca x.x.x.x:9710 –a adminuser -p adminpassword

Cause

The server name or IP address of the GroupWise domain server had been changed.