Environment
One SSO Provider 5.x, 6.x
Situation
After upgrading OSP, the catalina.out log during tomcat startup reports the following error:
Error loading configuration bootstrap XML: Class: XmlParseException
Class: LoggableMessage
Level: SEVERE
Code: internal.atlaslite.jcce.xml.w3c.XMLUtil.loadConfigFile() [2975]
Thread: localhost-startStop-1
Correlation Id: dd3e5bfe-ca01-421f-a09d-d1fb17b9124f
Text: An error occurred attempting to parse an XML document.
Root cause:
java.io.FileNotFoundException
/opt/netiq/idm/apps/tomcat/webapps/osp/WEB-INF/conf/current/bootstrapcfg.xml (No such file or directory)
java.io.FileInputStream: FileInputStream.java: open0: -2
java.io.FileInputStream: FileInputStream.java: open: 195
java.io.FileInputStream: FileInputStream.java: <init>: 138
java.io.FileInputStream: FileInputStream.java: <init>: 93
sun.net.www.protocol.file.FileURLConnection: FileURLConnection.java: connect: 90
Additionally, when attempting to access /idmdash or any other Identity Application, no login page is visible, and in it's place is this error:
{"Fault":{"Code":{"Value":"Sender","Subcode":{"Value":"XDAS_OUT_ENTITY_NON_EXISTANT"}},"Reason":{"Text":"Not found: idm"}}}
Resolution
There is a core file name change that occurred between OSP 6.0.0.5 and OSP 6.1.3 and later. If you modify the setenv.sh (setenv.bat for Windows) file to point to the new file name, the issue is resolved.
The default location for setenv.sh on Linux - /opt/netiq/idm/apps/tomcat/bin
The default location for setenv.bat on Windows - C:\netiq\idm\apps\tomcat\bin
- Stop tomcat.
- Open up the setenv file in a text editor.
- Under CATALINA_OPTS there should be a line:
- -Dcom.netiq.osp.ext-context-file=/opt/netiq/idm/apps/osp/lib/osp-conf.jar
- Change the osp-conf.jar to osp-conf-edir.jar.
- Save the change.
- Start tomcat.