Environment
Service Desk 7.x User Configuration
Situation
- Customer Orgs option is enabled in Setup > LDAP > [LDAP server] > Advanced
- Company field is set to an attribute that is not populated for the LDAP users
- LDAP Sync moves Customers from original Organizational Unit to the wrong one
- Customer to Item associations are lost
Resolution
- Option A:
Delete all Company Organizational Units except the desired one. - Option B:
For each user in LDAP, explicitly populate the attribute specified for Company in the Service Desk LDAP configuration.
Cause
This issue happens when the attribute specified for Company is not
explicitly set on the LDAP users. In this case, the LDAP sync in
Service Desk makes a guess at which Company Organizational Unit to
put the user into. If there is more than one Company Organizational
Unit defined in Service Desk, this leads to seemingly random
results.