Environment
GroupWise 18
Situation
GroupWise 18 Webaccess is running fine and users can log to their mailboxes with no problem, then when the SLES12 is restarted and now users, attempting to login to Webacces, get the browser error "Service unavailable", "Error 503".
Resolution
The "grpwise-tomcat8" daemon was not running. You could manually start it , but it does not autostart on server reboot. There were a few missing lines in the LSB header at the top of the "grpwise-tomcat8" script :
Non-working "grpwise-tomcat8" script ( this just shows the LSB header portion that chkconfig and the O.S will use to attempt to restart the service ) :
### BEGIN INIT INFO# Provides: grpwise-tomcat8 # Required-Start: $network $syslog # Required-Stop: $network $syslog # Default-Start: # Default-Stop: # Short-Description: start and stop tomcat ### END INIT INFO
You should be able to use chkconfig or systemctl to set "grpwise-tomcat8" auto restart :
like : chkconfig grpwise-tomcat8 on
or
systemctl enable grpwise-tomcat8
Now when the server restarts "grpwise-tomcat8 will auto restart.
Corrected LSB header in "grpwise-tomcat" script, just make it look like this and then it will auto restart :
### BEGIN INIT INFO # Provides: grpwise-tomcat8 # Required-Start: $network $syslog # Required-Stop: $network $syslog # Default-Start: 3 5 # Default-Stop: 0 1 2 6 # Short-Description: start and stop tomcat ### END INIT INFO
Cause
Missing information used by chkconfig and the operation system to auto restart the service.