Environment
GroupWise Mobility Service 2.0.1
GroupWise Mobility Service 2.1
GroupWise Mobility Service 2.1
Situation
In the GMS dashboad, seeing the following error for one or more accounts: "Invalid None folder encountered. Recommend that this user remove and re-add the account on device:"
Resolution
For GMS 2.1, build 230 only, open a service request with technical support and request the ping.py and sync.py files from defect # 912117.
With these updated files, instead of preserving folderId's across re-initialization, GMS will now just create a delete event for any invalid folderId that the device sends in a sync or ping request.
This fix is also included in GMS2014 and GMS18 versions as well.
With these updated files, instead of preserving folderId's across re-initialization, GMS will now just create a delete event for any invalid folderId that the device sends in a sync or ping request.
This fix is also included in GMS2014 and GMS18 versions as well.
Cause
When a certificate is changed or when a user is re-initialized (or removed and re-added to GMS), the FolderId's of the user-created folders are re-generated. This causes the need for the user to remove and re-add the account on some devices. Failure to remove and re-add the account may produce the Invalid None Folder Encountered error since the FolderId's no longer match up.