Closest Server Rules List is blank

  • 7022493
  • 20-Dec-2017
  • 26-Dec-2017

Environment

ZENworks Configuration Management 11.4
ZENworks Configuration Management 2017

Situation

Closest Server Rule List on managed device is blank

Resolution

-Removed the registry key; HKLM\Software\Novell\ZCM\Volatile\RebootlessSystemUpdate=True
-Refresh agent
-Checked xml files are updated with respective server list, located in %ZENworks_Home%\cache\zmd\locationconfig
-Reboot the device

Cause

Once the Closest Server Rules List is blank is in this state, the device becomes disconnected.
This can occur when;
The Location has "Exclude the Closest Server Default Rule" checked and Servers are not listed.
Rebootless Agent install - awaiting reboot



Additional Information

Deploying the ZENworks Adaptive Agent from ZCC System Updates pane;

Step 2: Choose the Reboot Behavior for the Deployment
Selecting "Do not reboot the device" and checking "Start ZENworks Agent with limited functionality"
This will deploy the full agent but without a reboot it will only have limited functionality.
Be sure to reboot within a short amount of time, hours, days, allowing the Agent to receive all configurations.



Indicators:
ZCC > Configuration  > System Update > Device Pending will show Status "Awaiting Reboot"
System Update logs will have;
Files named: reboot_needed_but_suppressed and update_needs_reboot
system-update.log will indicate [AWAITING_REBOOT]
Registry will have;
HKLM\SOFTWARE\Novell\ZCM\Volatile\RebootlessSystemUpdate=True