HTTP Error 500 after appliance upgrade to 5.0

  • 7022362
  • 20-Nov-2017
  • 20-Nov-2017

Environment

Change Guardian 5.0

Situation

Unable to log in to the CG webui after upgrading CG Appliance to version 5.0.
This situation can occur from a previous version or 4.2.1 - Appliance and upgraded using zypper patch. Install.log will show a successful upgrade.

Browser Error after login:
HTTP ERROR 500
Problem accessing /sentinel/. Reason: 
Server Error
Caused by:
java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
        at java.util.ArrayList.rangeCheck(ArrayList.java:653)
        at java.util.ArrayList.get(ArrayList.java:429)
        at org.apache.jsp.index_jsp._jspService(org.apache.jsp.index_jsp:82)
        at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:111)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:848)
        at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:403)
        at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:492)
        at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:378)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:848)
        at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:684)
        at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:503)
        at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:137)
        at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:575)
        at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:231)

CG Server.0.1.log Error:
2017/11/15 11:08:52 | INFO   | jvm 1    | Wed Nov 15 11:08:52 GMT 2017|WARNING|qtp960560437-287|esecurity.base.util.JavaLoggingLog4jAppender.append
2017/11/15 11:08:52 | INFO   | jvm 1    | /sentinel/views/logon.html
2017/11/15 11:08:52 | INFO   | jvm 1    | java.lang.IndexOutOfBoundsException: Index: 0, Size: 0

Resolution

Add the following entries in the  /etc/opt/novell/sentinel/config/ui-configuration.properties file

webui.productName=Change Guardian
webui.CompanyName=NetIQ

Cause

Root cause of the issue is in the codebase. The issue is already addressed and will be available to our customers in the next Change Guardian Release (5.1.0)