Unable to add a WalkUp printer

  • 7022300
  • 09-Nov-2017
  • 09-Nov-2017

Environment

iPrint Appliance 3.x

Situation

When attempting to add a WalkUp printer an error is generated during the final step.  The error states. "An error has occurred.  See the server logs for additional information".

Resolution

Restart the iPrint mobile server.
1) Open a putty session to the iPrint Appliance and log in as root
2) Type: rcnovell-iprint-mobile restart

After the iPrint mobile server has restarted, try creating the WalkUp printer again. (See Additional Information below)

Cause

The iPrint Appliance is stuck in a state that does not allow updates to be made to the database.

Additional Information

Although an error occurs during the creation of the WalkUp printer and no WalkUp printer shows in the list, an eDirectory object for the printer does get created.  Prior to attempting to create the WalkUp printer again, you must delete the WalkUp printer object using iManager.  In iManager, use the Delete Print Object under the iPrint Roles and Tasks.

In this case, the server logs the error is referring to is the /var/opt/novell/log/iprintmobile/iprintmobile0.log.  In this specific situation, you may see an error similar to this:
Nov 07, 2017 11:57:17 AM com.novell.service.iprint.persistence.orientdb.repository.support.AbstractOrientObjectRepository saveAndGet
WARNING: Failed to save the instance in Datastore. Error in data flush background thread, please restart database and send full stack trace inside of bug report
    DB name="iprint"