Environment
Micro Focus iPrint Appliance 3.1
Situation
When sending a print job through the iPrint mobile app (Android or iOS), the job is sent with no errors. However, the print queue status shows pending-held and does not change.
Resolution
- Go to the iPrint Management Console
- https://<ip or dns>:9443
- Manage iPrint appliance
- Renderers
- Local Renderer
- Edit
- If Unable to connect to renderer is returned or if the driver selection is empty, continue with the steps below.
- Type the following commands a terminal session (putty or other tool):
- rcnovell-iprint-mobile stop
- orientdb-console
- connect plocal:/var/opt/novell/iprintmobile/databases/iprint admin admin
- select * from GlobalConfiguration;
- If the driverID field is populated (shows the generic driver), reach out to Micro Focus Customer Support.
- If the driverID field is empty, run this update command:
- update GlobalConfiguration SET driverId="Generic+PostScript+Printer+Foomatic%2FPostscript+%28recommended%29";
- Note: Depending on your browser settings, the above update command may show as being wrapped. However, the command is one line and should be run as one line.
- quit
- rcnovell-iprint-mobile start
- Repeat steps 1 through 6. Verify no error is returned and that the driver selection is populated.
- Test printing. It should work without error.
Cause
During the migration from the Appliance 2.x to 3.1, the driverID information is not properly copied to orientdb.