"Failed to print the job. Error occurred during document conversion" when submitting a print job via email

  • 7022227
  • 27-Oct-2017
  • 07-Nov-2017

Environment

Micro Focus iPrint Appliance 3.1

Situation

Submitting a print job via email fails with the error:
Failed to print the job. Error occurred during document conversion

Job List

Document: EmailBody.html
Status: Error in document conversion, or invalid page range. Supported document formats include Open Office, Microsoft Office, PDF, image and text files.

Resolution

  1. Go to the Appliance Management Console:
    • https://<ip or dns>:9443
  2. Manage iPrint Appliance
  3. Renderers
  4. Select iPrint Local Renderer
  5. Edit
  6. Change the default printer driver to Generic PCL 4 Printer Foomatic/laserjet (recommended).
  7. Click Commit.
  8. Logout of the MC
  9. Log in, go back to the same page and change the default printer driver back to Generic Postscript Printer Foomatic/Postscript recommended
  10. Click Commit.
Send an email.  Verify the problem does not happen.

Cause

CUPS links got broken during the migration from Appliance 2.x. The above steps will reset the proper links.