Environment
Micro Focus Vibe 4.0.3
Micro Focus Vibe 4.0.2
Novell Vibe 4.0.1
Novell Vibe 4.0
Applies only when Vibe is deployed as a cluster and used with NetIQ Access Manager(NAM).
Micro Focus Vibe 4.0.2
Novell Vibe 4.0.1
Novell Vibe 4.0
Applies only when Vibe is deployed as a cluster and used with NetIQ Access Manager(NAM).
Situation
Users randomly get a RPC token error on-screen when trying to access Vibe in a browser:
"Checking the GWT RPC XSRF/CRSF token detected an XSRF/CSRF (Cross-Site Request Forgery) failure. Contact your site administrator about this problem. (Error details: 'Invalid RPC token (Invalid XSRF token.)'.)"
"Checking the GWT RPC XSRF/CRSF token detected an XSRF/CSRF (Cross-Site Request Forgery) failure. Contact your site administrator about this problem. (Error details: 'Invalid RPC token (Invalid XSRF token.)'.)"
Resolution
Login to NAM admin console.
1. Navigate to (Nam Admin Console -> Access gateway -> [AG-Cluster]->[Proxy Server] ->Web Servers)
2. Check if the admin has checked the 'Enable Session Stickiness' option
3. 'Session Stickiness' should be enabled under the Vibe reverse proxy config
4. Apply NAM configuration.
5. Clear end user browser cache before accessing Vibe again
The issue should now be resolved. See Vibe documentation for reference : https://www.novell.com/documentation/vibe4/vibe4_admin/data/blpk97e.html
1. Navigate to (Nam Admin Console -> Access gateway -> [AG-Cluster]->[Proxy Server] ->Web Servers)
2. Check if the admin has checked the 'Enable Session Stickiness' option
3. 'Session Stickiness' should be enabled under the Vibe reverse proxy config
4. Apply NAM configuration.
5. Clear end user browser cache before accessing Vibe again
The issue should now be resolved. See Vibe documentation for reference : https://www.novell.com/documentation/vibe4/vibe4_admin/data/blpk97e.html
Cause
The issue occurs due to an incorrect NAM Server setting for the Vibe reverse proxy.