Blank page when attempting to self-register external Filr user

  • 7022050
  • 09-Oct-2017
  • 10-Oct-2017

Environment

Filr 3.2

Situation

When an external user clicks on the "Self Registration Required" link in the email the receive from the Filr appliance, the page is empty.

Resolution

Correct the port designated for HTTP connections:

  1. Navigate to the "Reverse Proxy" section of Filr. Path: Port 9443 Filr Appliance Console > Configuration > Reverse Proxy.
  2. Change the "Reverse Proxy Secure HTTP Port:" setting from 443 to 8443.  
  3. Reconfigure Filr.

Cause

The server is listening on port a port different from the one included in the emailed link.

The link supplied in the email includes (or implies, if not specified) a port number over which the TCP/IP connection to the server is to be made. Examine the link in the email. If you see something like

https://filr.mycompany.com...
or
https://filr.mycompany.com:443...

Then you will be attempting to connect to the Filr server on port 443. If you see something like

https://filr.mycompany.com:8443...

Then you will attempt to connect on port 8443.

If the Filr server is listening on a port other than what is included in the emailed link, the attempt to connect to the server will fail.