Ganglia page not accessible on iPrint Appliance 3.0

  • 7021946
  • 29-Sep-2017
  • 03-Oct-2017

Environment

Micro Focus iPrint Appliance 3.0

Situation

When accessing the Ganglia web page (https://<host>:9443/gweb/) the following message is return
Page is not loaded
When accessing the page directly (https://<host>:9443/gweb/index.php), the page does not load, but is downloaded to the workstation.

Resolution

  1. Verify the Apache mode is running in the worker mode:
    • At a terminal session (putty or otherwise), run this command:
      • ps -ef | grep httpd
        • If the processes look like this:
          • /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -DSSL
        • then the Apache is running in prefork mode.  Do not continue to the next step.
        • If the processes look like this:
          • /usr/sbin/httpd2-worker -f /etc/apache2/httpd.conf -DSSL
        • then the Apache mode is running in worker mode. Continue to the next step.
  2. Change the Apache mode from worker to prefork by copying and pasting the following string of commands into the iPrint Appliance terminal session:
    • sed -i -e 's/APACHE_MPM="worker"/APACHE_MPM=""/g' /etc/sysconfig/apache2;sed -i -e 's/APACHE_MODULES="/APACHE_MODULES="php5 /g' /etc/sysconfig/apache2;rcapache2 restart

Cause

The iPrint Appliance ships with the Apache configuration in prefork mode. When changing the Apache configuration to worker mode, php5 must be removed.  Ganglia requires php5 to function.