Reflection 14.1 Damaged Installation Error with Windows Update KB3072630

  • 7021742
  • 20-Aug-2015
  • 31-Mar-2018

Environment

Reflection X version 14.1
Reflection Suite for X version 14.1
Reflection for UNIX and OpenVMS version 14.1
Reflection FTP Client version 14.1

Situation

Reflection 14.x applications may fail to start after installing a Microsoft Windows Security Update (published 13-Jul-2015).

When opening Reflection FTP Client or Reflection for UNIX and OpenVMS, you may see the following error:

Figure 1. Reflection error: 'The installation data associated with this product is damaged. Please reinstall the product.' 
Figure 1. Reflection error: 'The installation data associated with this product is damaged. Please reinstall the product.'

When opening Reflection X, you may see the following error:

View Full Size
Figure 2. Error: 'Reflection X has not been installed correctly. Please run Setup... (RX267)'
Figure 2. Error: 'Reflection X has not been installed correctly. Please run Setup... (RX267)'

Resolution

This issue is addressed in Reflection 14.1 products beginning in version 14.1.4.487 (identified as version 14.1.4487 in Control Panel > Programs), which includes Reflection FTP Client version 14.1.556 or higher. Maintained customers can obtain and apply Reflection 14.1 Service Pack 4 Update 1 (version 14.1.4.489) or higher. For more information, see KB 7021743.

Alternatively (not recommended), remove the installed update KB 3072630 in Windows Control Panel > Programs.

Cause

This issue has been associated with Windows Update KB 3072630, which published in July 2015. This issue may also be related to certain uninstall and reinstall scenarios.

Additional Information

Legacy KB ID

This document was originally published as Attachmate Technical Note 2811.

Feedback service temporarily unavailable. For content questions or problems, please contact Support.