Signing Principal Error when Deploying Host Integrator Model

  • 7021309
  • 02-May-2014
  • 12-Mar-2018

Environment

Verastream Host Integrator version 7.5 or higher

Situation

When deploying a model to your Verastream Host Integrator (VHI) server (using Design Tool or the activatemodel command), you may see the following errors 3851 and 3852:

[VHI 3851] The current model could not be deployed to the Verastream Host Integrator server "servername".
[VHI 3852] Deployment of model failed: Cannot establish management session with VHI server 'servername'
[VHI 3852] Deployment of model failed: Signing principal does not match token issuer.

In Design Tool, some of the above errors are visible after you click the Details button:

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Figure 1: Deployment error details
Figure 1: Deployment error details

Resolution

To resolve this issue, remove and re-add the session server in the management cluster as described below.

Note: After completing these steps, the session server configuration remains intact (deployed models, session pools, etc.).

  1. On a Windows system, run the Administrative Console application.
  2. Connect and log into the management server using administrative credentials.
  3. If the Session Server Explorer view is not visible, click Perspective > Host Integrator > Session Servers.
  4. Within the Installation > Servers tree node, note your session server name (as you will re-enter it below).
  5. Right-click your server and click Remove.
  6. Right-click Servers and click Add Session Server.
  7. Enter your session server name and click OK.

Re-try your model deployment. If the problem persists, unregister the session server from the management server as follows:

  1. Stop the session server service as described in KB 7021352.
  2. Run the following command (as administrator, since it requires operating system elevation):

Windows: %VHI_ROOT%\bin\resetsessionserver.bat

UNIX/Linux: /opt/attachmate/verastream/hostintegrator/bin/resetsessionserver.sh

  1. Start the session server service as described in KB 7021352.
  2. Repeat steps 1 through 7 above.

Note: After completing these steps, the session server configuration remains intact (deployed models, session pools, etc.).

Cause

A security token retrieved by the deployment tool from the management server is bad, or the token verification by the session server has failed (certificate from the management server does not match).

Additional Information

Legacy KB ID

This document was originally published as Attachmate Technical Note 10158.